Disruption in VISA card payments

Minor incident Barion Smart Gateway UI
2024-10-18 15:22 CEST · 2 days, 5 hours, 25 minutes

Updates

Resolved

Issue resolved.

October 18, 2024 · 16:39 CEST
Investigating

We are currently investigating the issue.

October 18, 2024 · 15:26 CEST
Issue

Customers may experience unsuccessful payments when paying with VISA cards.

October 18, 2024 · 15:22 CEST

← Back