Distruptions in 3D Secure authentication process during card payments

Minor incident Barion Secure Web
2021-10-15 08:00 CET · 5 hours, 25 minutes, 52 seconds

Updates

Resolved

The 3D Secure service disruption at Mastercard has apparently been resolved. We will continue to monitor the bank card payment flow and check for any resurfacing problems.

October 15, 2021 · 13:25 CET
Update

A global service disruption has been identified at Mastercard, which impacts all issuers. Mastercard is working on fixing the issue. We are currently awaiting updates.

October 15, 2021 · 12:06 CET
Investigating

Disruptions reported during card payments when performing 3D Secure authentication. The process on the payment gateway is reportedly stuck without any error message. We are investigating the issue.

October 15, 2021 · 11:48 CET

← Back